Welcome to ask.woodem.org. You may post when you login through your GitHub account.

install woo on window subsystem Linux

0 votes
42 views
asked Sep 4 by trucgiao91 (370 points)

Hi, 

I am trying to install woo from window subsystem linux, however until step python3 woo-install.py and encountered the error as shown:

 

Do you have any idea how to solve this?

commented Sep 5 by eudoxos (47,770 points)

Oh, that is an error in the script. I just commited a fix to github, please try with the newest version. Could not test much.

commented Sep 11 by trucgiao91 (370 points)

Hi Vaclav,

I now have ubuntu on my pc. After installation, I open woo, the simulation runs normally but whenever I open 3D scene, the software shows error and shut down the program. Do you have any idea? I actually had the same problem when installed YADE once.

error msg

commented Sep 14 by eudoxos (47,770 points)

Is that under Windows (in WLS) or in standalone Ubuntu installation? Either way, try to run woo with "LIBGLALWAYSSOFTWARE=1 woo" which will force software rendering (without acceleration), that way you will see where is the problem. HTH, Vaclav

commented Sep 16 by trucgiao91 (370 points)
edited Sep 16 by trucgiao91

Hi Vaclav,

Its Ubuntu not WLS. Sorry I dont understand what you meant by run woo with LIBGLALWAYSSOFTWARE=1 woo. I tried to run it as typing in the terminal but the problem is not fixed. I will try with other laptop to see if the problem persists. But thank so much for your support!

I also tried to install it on my department's server (debian OS ) but also encountered the problem (some files are not found). Are the commands

sudo add-apt-repository ppa:eudoxos/woo-daily
sudo apt-get update
sudo apt-get install python3-woo
enter image description here
only for ubuntu ?
(sorry for confusing you with many installation from different OS)
Kind regards,
Giao

commented Sep 21 by eudoxos (47,770 points)

His, sorry for the mess about packaging. The best is to use source - the same script scripts/woo-install.py will install on Ubuntu for you, plus you can update very easily (woo -RR and it's done). Debian's packages ale lagging behind, they have not updated those in a while, and I think ubuntu packages in the woo-daily ppa might be broken as well. I will try to look at that as soon as I can. But the source is the best. Cheers, v.

commented Sep 21 by eudoxos (47,770 points)

The LIBGLALWAYSSOFTWARE switches off 3d acceleration for the program. So you type LIBGLALWAYSSOFTWARE=1 woo (enter) and see if it still crashes.

commented Sep 21 by trucgiao91 (370 points)

Hi Vaclav,

The ubuntu now works when I tried to compile it on different computer. Thanks for your help. Please let me know if you have any further plan for the Debian's package.

Best regards,
Giao

commented Sep 23 by eudoxos (47,770 points)

Package maintenance is quite difficult, especially for evolving code. Then it takes months till the newer version gets to users; the PPA is quicker, but mut also be maintained. If you can stick to the source, better for you. I will let you know if something changes with packaging.

PS please make sure you use python3 (or slowly switch over - not a big change for scripts, mostly changing print a to print(a)), woo will not run on python2 forever (python2 itself is considered deprecated for about 5 years now).

Please log in or register to answer this question.

...