Welcome to ask.woodem.org. You may post when you login through your GitHub account.

WOODEM crashes on clump generator

0 votes
21 views
asked Jun 20 by andrewDEM (340 points)
retagged Jun 20 by eudoxos

Hi Vaclav,

I updated WOODEM using woo --RR to use the latest feautres (variableVelocity). However, after updating WOO, none of my old models would run. WOODEM crashes right away with the following message:

WARN  /home/andres/woo/pkg/dem/Psd.cpp:216 critDt: Not yet implemented, returning perhaps bogus value from PsdSphereGenerator::critDt!!
Floating point exception (core dumped)

I checked that I have enough space and also uninstalled and reinstalled WOO, but I'm still getting it to crash.

Thanks!

Andrew

P.S. Here's the entire message for the record:

Welcome to Woo ver. 1.0.82+git.ee8115d, API 10103
Running script loadbox06.py
/usr/lib/python3/dist-packages/past/builtins/misc.py:79: DeprecationWarning: 'U' mode is deprecated
  with open(filename, "rbU") as fin:
Dense packing tiling: Vector3i(16,4,8)
hash version 2Vector3(1.4948221931582717,2.6930433625398544,2.6930433625398544)woo.dem.PsdClumpGenerator(save=True, discrete=False, psdPts=[(0.15, 0), (0.2, 1)], mass=True, clumps=[woo.dem.SphereClumpGeom(scaleProb=[], clumped=True, centers=[(0, 0, 0), (1, 0, 0), (0, 1, 0), (0, 0, 1)], radii=[1, 1, 1, 1])], scaleMethod='equiv', genClumpNo=[], oris=[], oriFuzz=[])
Memoize file is ./e444c136d2f454274838f78d4c976114dcc1775b.randomdense
WARN  /home/andrew/woo/pkg/dem/Psd.cpp:216 critDt: Not yet implemented, returning perhaps bogus value from PsdSphereGenerator::critDt!!
Floating point exception (core dumped)

 

1 Answer

0 votes
answered Jun 20 by eudoxos (44,970 points)
selected Jun 21 by eudoxos
 
Best answer

Hi Andrew,

crash is always a bug which should not happen. I cannot determine the cause straight away (I don't think it is in the clump generator; critDt is normally only called before engine loop is started, the warning about critDt is most likely unrelated) and unfortunately the exception just crashed woo instead of propagating up and giving useful information.

  •  Can you re-try after you delete the ./e444c136d2f454274838f78d4c976114dcc1775b.randomdense file? It might help (but unlikely) if there is some garbage in that file. But you said it used to work with the previous version fine, so it is unlikely to help.
  • If that does not help, obtaining a MWE (minimal crasher) would help -- stripping your script of bits and pieces, then I can have a look.
  • Another option, the best, is if you can compile woo with debugging: go to the source directory (~/woo or such) and run scons debug=1. This will install debugging version of woo, which you can invoke with woo -D loadbox06.py. This type of error is likely to cause some more meaningful message (full stack trace should be printed -- can be many screen -- and providing this one will quickly lead to finding the cause).
  • If you still get uninformative crash, run woo -D --in-gdb loadbox06.py; this will drop you into debugger at the moment of crash (like starting with (gdb) and saying thread apply bt full should give you backtrace for all threads.

Please let me know how it goes, I will give you as much assistance as possible.

Vaclav

commented Jun 20 by andrewDEM (340 points)

Hi Vaclav,

thanks for the help!

I tried both woo -D and woo -D --in-gdb. The error points to: InsertionSortCollider ... Assertion `iBegin<iEnd' failed.

WARN /home/andrew/woo/pkg/dem/Psd.cpp:216 critDt: Not yet implemented, returning perhaps bogus value from PsdSphereGenerator::critDt!!
python3: /home/andrew/woo/pkg/dem/InsertionSortCollider.cpp:746: void InsertionSortCollider::insertionSortPeri_part(InsertionSortCollider::VecBounds&, bool, int, long int, long int, long int): Assertion `iBegin<iEnd' failed.
Thread 1 "python3" received signal SIGABRT, Aborted.

Please let me know if there is something that I could try now, otherwise I could send you the minimal crasher model (MWE), which is simple and less than a page long.

Just to recap: it is happening to all of my models, I have tried deleting the .randomdense file, and I have tried re-install WOO. Also, this seemed to happened after I did WOO -RR to update it.

Thanks!

Andrew

commented Jun 20 by eudoxos (44,970 points)

Okay, thanks. Please update from git again. I saw this assertion error here already a few days back (it is an error created as side-effect of a later commit), fixed it, but forgot to commit to github. If you update to the latest 8003ae5 by woo -RR -D loadbox06.py, you will either see the error go away (best) or it will crash somewhere else (the original crash spot; assertion checks are discarded in non-debug builds, so it might be something else yet). If it is fixed, re-compile also the release version (woo -R) and be happy. If not, get back. Cheers! v.

commented Jun 20 by andrewDEM (340 points)

Thanks Vaclav!

the latest WOO from github worked by running woo -RR . There are no more errors.

Thanks!

Andrew

commented Jun 20 by eudoxos (44,970 points)

Great! Sorry for the complication, especially since I had it fixed here already. Happy Woo'ing! v.

...