Welcome to ask.woodem.org. You may post when you login through your GitHub account.

Compile Woo on Ubuntu 16.04

+1 vote
118 views
asked Oct 11, 2016 by xuhenry (210 points)

Dear all,

    I'm compiling Woo on Ubuntu 16.04 according the document as follows:

   sudo add-apt-repository ppa:eudoxos/woo-daily
sudo apt-get update
sudo apt-get install python3-woo  

sudo apt-get install python-pip

sudo pip install --system 'ipython>=5.0'

However, there are still some errors.:

 

Welcome to Woo ver. 1.1+3985+40~ubuntu16.04.1, API 10103
---------------------------------------------------------------------------
ValueError                                Traceback (most recent call last)
/usr/bin/woo in <module>()
      7 if __name__ == '__main__':
      8     sys.exit(
----> 9         load_entry_point('woo===1.1-3985-40-ubuntu16.04.1', 'console_scripts', 'woo')()
     10     )

/usr/lib/python3/dist-packages/wooMain.py in main(sysArgv)
    327     #
    328     try:
--> 329         import woo.qt # this import fails if running with -n or $DISPLAY can't be connected to
    330         if 'qt4' in woo.config.features: gui='qt4'
    331         else: gui='qt5'

/usr/lib/python3/dist-packages/woo/qt/__init__.py in <module>()
    107                 # this is deprecated in IPython >= 5.x
    108                 import IPython.lib.inputhook #guisupport
--> 109                 wooQApp=IPython.lib.inputhook.enable_gui(gui='qt4' if 'qt4' in woo.config.features else 'qt5')
    110
    111             #from IPython.lib.guisupport import start_event_loop_qt4

/usr/lib/python3/dist-packages/IPython/lib/inputhook.py in enable_gui(gui, app)
    538     except KeyError:
    539         e = "Invalid GUI request %r, valid ones are:%s" % (gui, guis.keys())
--> 540         raise ValueError(e)
    541     return gui_hook(app)
    542

ValueError: Invalid GUI request 'qt5', valid ones are:dict_keys(['pyglet', 'qt', None, 'gtk', 'qt4', 'none', 'glut', 'tk', 'osx', 'wx', 'gtk3'])

 

Is there anyone can help me?

Furthermore, How can I compiled Woo with source on Ubuntu 16.05 and QT5?

Thanks a lot!
Best regard!

 

Henry

1 Answer

0 votes
answered Oct 11, 2016 by MarcoTar (770 points)
selected Oct 21, 2016 by eudoxos
 
Best answer

Hi Henry.

I just updated woo from an old version to the latest one recently.

Actually, from your description, I observe some doubts which maybe help you.

1.

sudo pip3 install --system 'ipython>=3.0,<4'     # installation for all users

This is what the Documentation writes instead of what you tell here

sudo pip install --system 'ipython>=5.0'

2. Check from your Terminal if you have installed 'Python3' instead of 'iPython' or 'Python.x'. That's the crucial part from my point of view. If you didn't, you can install from your terminal through type sudo -apt...... which you can find from the website.

HTH

Kind Regards

Feixiang Xuan

commented Oct 11, 2016 by xuhenry (210 points)

Dear Dr. Xuan,
Many thanks for you help!
Best regards,
Henry

commented Oct 11, 2016 by eudoxos (44,890 points)

Hi, actually IPython 5.x will work now as well (the support was added meanwhile, I will update the docs). The important point that Feixiang raises is to use "pip3" instead of "pip" when using python3.

...