Welcome to ask.woodem.org. You may post when you login through your GitHub account.

Windows binary installation

0 votes
98 views
asked Mar 1, 2016 by lgchemer (120 points)

Hello. I downloaded Woo-main-1.0-r3936-git-07be000-installer.exe and try to install it, but the installer keeps saying "Must be installed into the same directory as Woo-libs" (image attached below)

I tried to install the software in the folder Woo-libs as suggested (It didn't exist, so I created), but it still does not work. Would you pls shed some lights on this?

Thanks.

1 Answer

0 votes
answered Mar 1, 2016 by eudoxos (45,050 points)
Hi, there is no need to create the directory yourself, if you just use the defaults for both Woo-libs and Woo-main, it should work. Cannot try myself having no Windows box around at the moment, sorry. Get back if it does not work. The Windows port receives only little maintenance (due to lack of volunteers and also people actually using Windows) but I've never encountered a problem with installation.

Libs and main are split since libs (which contains all 3rd-party libs) are only rarely updated and the idea was to limit download size when you update only Woo itself. That's why it check it goes to the same location, since otherwise Woo would not run.

Cheers, Vaclav
commented Mar 1, 2016 by lgchemer (120 points)

Thank you for reply.
I closed the pop ups notifying me of "Must be installed into the same directory as Woo-libs." However, as you can see below, the install button is grayed out, so I can't click to move on to the next installation step.

enter image description here

commented Mar 2, 2016 by eudoxos (45,050 points)

Huh, what are those funny chars (W struck out)? Is that the default which is offered got both Libs and Woo itself? What is your platform, what language and such? Try to manually put in backslashes, it should let you install once the path is something meaningful.

commented Mar 2, 2016 by lgchemer (120 points)
  • Sorry for the confusion. I am using Korean font, so the character (W struck out) indeed works as backslash. The character looks weired, but it didn't make any problem in my life and all the Windows computer in Korea (AFAIK).
  • Whatever path (default or whatever folder I changed) does not work. Install button still stays gray.
...