Welcome to ask.woodem.org. You may post when you login through your GitHub account.

Ubuntu 15.10 unmet dependency libvtk5.8v5

0 votes
181 views
asked Oct 25, 2015 by steps39 (170 points)
I am trying to install woodem on Ubuntu 15.10 using the ppa, but it fails with unmet dependency libvtk5.8v5 - could the dependencies be changed to allow higher versions of libvtk to satisfy woodem's needs?  Or else any other suggestions on how to fix this would be great.

Thanks, Simon

1 Answer

+1 vote
answered Oct 26, 2015 by eudoxos (48,570 points)

Hi Simon, this is a bit strange, 15.10 should build against qt5 and vtk6. I will double-check, the packages are quite fresh (just like 15.10 itself) and may have some issues. Please also note that 15.10 has some outdated packages which will fail with woo (in particular, the packaged ipython does not support qt5 yet -- you will have to install those through pip, but it should eventually work).

Your best bet is to compile from sources, using qt4 (or qt5 and ipython from pip) and vtk6 as explained here, something like scons features=qt4,vtk,opengl,openmp,gts CPPPATH=/usr/include/vtk-6.2:/usr/include/eigen3 (the CPPPATH is needed to select the right VTK lib).

I check the package and let you know. If you go the source-compilation way, please also keep me updated here.

Cheers, Václav

commented Oct 26, 2015 by eudoxos (48,570 points)

I am able to reproduce your problem in VM with 15.10. I see now that the last successful build was with an older revision, all the subsequent build (with vtk6) were failing. Rebuilding now, let's see how it goes.

commented Oct 26, 2015 by steps39 (170 points)

Václav, Thanks very much, I'll let you know how I get on. Simon

commented Oct 26, 2015 by eudoxos (48,570 points)

Looking at buildlog https://launchpadlibrarian.net/222878536/buildlog_ubuntu-wily-i386.woo_1.1%2B3938%2B36~ubuntu15.10.1_BUILDING.txt.gz, it fails to test the built module for python 3.5. I will have to check how to make the module available to all python versions, using dh_python3 and friends. I will check that later this week and let you know here. If I forget, don't hesitate to open an issue at https://github.com/woodem/woo/issues so that it is fixed.

...